import Foundation
let pattern = #"<<<<<<<(?:\r?\n|.)*=======(?:\r?\n|.)*>>>>>>>.*\r?\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/**********************************
!&DOC-TECHNIQUE ! src/cmm/bacchus/b
!===============!==================
!&Fiche Du ! S.! Operateu
!__________________!___!___________
<<<<<<< HEAD
=======
! 2017-07-13! !Michèle ROY
>>>>>>> 157443 - DRM-CIEL
!__________________________________
!
!__________________________________
&End
***********************************
{d-brokmini.i}
{bt-expciel.i }
{maquette.i }
{tabsoc.i }
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)