import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<<<<<<<(?:\\r?\\n|.)*=======(?:\\r?\\n|.)*>>>>>>>.*\\r?\\n";
final String string = "/**********************************\n"
+ "!&DOC-TECHNIQUE ! src/cmm/bacchus/b\n"
+ "!===============!==================\n"
+ "!&Fiche Du ! S.! Operateu\n"
+ "!__________________!___!___________\n"
+ "<<<<<<< HEAD\n"
+ "=======\n"
+ "! 2017-07-13! !Michèle ROY\n"
+ ">>>>>>> 157443 - DRM-CIEL\n"
+ "!__________________________________\n"
+ "! \n"
+ "!__________________________________\n"
+ "&End \n"
+ "***********************************\n\n"
+ "{d-brokmini.i}\n"
+ "{bt-expciel.i }\n"
+ "{maquette.i }\n"
+ "{tabsoc.i }\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}