use strict;
my $str = '/**********************************
!&DOC-TECHNIQUE ! src/cmm/bacchus/b
!===============!==================
!&Fiche Du ! S.! Operateu
!__________________!___!___________
<<<<<<< HEAD
=======
! 2017-07-13! !Michèle ROY
>>>>>>> 157443 - DRM-CIEL
!__________________________________
!
!__________________________________
&End
***********************************
{d-brokmini.i}
{bt-expciel.i }
{maquette.i }
{tabsoc.i }
';
my $regex = qr/<<<<<<<(?:\r?\n|.)*=======(?:\r?\n|.)*>>>>>>>.*\r?\n/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}