re = /<<<<<<<(?:\r?\n|.)*=======(?:\r?\n|.)*>>>>>>>.*\r?\n/m
str = '/**********************************
!&DOC-TECHNIQUE ! src/cmm/bacchus/b
!===============!==================
!&Fiche Du ! S.! Operateu
!__________________!___!___________
<<<<<<< HEAD
=======
! 2017-07-13! !Michèle ROY
>>>>>>> 157443 - DRM-CIEL
!__________________________________
!
!__________________________________
&End
***********************************
{d-brokmini.i}
{bt-expciel.i }
{maquette.i }
{tabsoc.i }
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end