# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([2-9]{1})([0-9]{2})([\s.-]?)([2-9]{1})([0-9]{2})([\s.-]?)([0-9]{4})$"
test_str = ("212-222-1010\n"
"(203)753-5678\n"
"(203) 753-5678\n"
"201-853-6909\n"
"800-289-2583\n"
"215 5551212\n"
"515555121200000\n"
"201.853.6909\n"
"201 853 6909\n"
"201-853-6909\n"
"201 853 6909\n"
"101.853.6909\n"
"1018536909\n"
"666-666-6669\n"
"(208) 555-1234\n"
"666-666-666\n"
"666 666 6666\n"
"666.666.6666\n"
"555 555 5555\n"
"222-222-2222\n"
"123-123-132\n"
"236-548-9888")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.