#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([2-9]{1})([0-9]{2})([\s.-]?)([2-9]{1})([0-9]{2})([\s.-]?)([0-9]{4})$"
Local $sString = "212-222-1010" & @CRLF & _
"(203)753-5678" & @CRLF & _
"(203) 753-5678" & @CRLF & _
"201-853-6909" & @CRLF & _
"800-289-2583" & @CRLF & _
"215 5551212" & @CRLF & _
"515555121200000" & @CRLF & _
"201.853.6909" & @CRLF & _
"201 853 6909" & @CRLF & _
"201-853-6909" & @CRLF & _
"201 853 6909" & @CRLF & _
"101.853.6909" & @CRLF & _
"1018536909" & @CRLF & _
"666-666-6669" & @CRLF & _
"(208) 555-1234" & @CRLF & _
"666-666-666" & @CRLF & _
"666 666 6666" & @CRLF & _
"666.666.6666" & @CRLF & _
"555 555 5555" & @CRLF & _
"222-222-2222" & @CRLF & _
"123-123-132" & @CRLF & _
"236-548-9888"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")