import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([2-9]{1})([0-9]{2})([\\s.-]?)([2-9]{1})([0-9]{2})([\\s.-]?)([0-9]{4})$";
final String string = "212-222-1010\n"
+ "(203)753-5678\n"
+ "(203) 753-5678\n"
+ "201-853-6909\n"
+ "800-289-2583\n"
+ "215 5551212\n"
+ "515555121200000\n"
+ "201.853.6909\n"
+ "201 853 6909\n"
+ "201-853-6909\n"
+ "201 853 6909\n"
+ "101.853.6909\n"
+ "1018536909\n"
+ "666-666-6669\n"
+ "(208) 555-1234\n"
+ "666-666-666\n"
+ "666 666 6666\n"
+ "666.666.6666\n"
+ "555 555 5555\n"
+ "222-222-2222\n"
+ "123-123-132\n"
+ "236-548-9888";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}