using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([2-9]{1})([0-9]{2})([\s.-]?)([2-9]{1})([0-9]{2})([\s.-]?)([0-9]{4})$";
string input = @"212-222-1010
(203)753-5678
(203) 753-5678
201-853-6909
800-289-2583
215 5551212
515555121200000
201.853.6909
201 853 6909
201-853-6909
201 853 6909
101.853.6909
1018536909
666-666-6669
(208) 555-1234
666-666-666
666 666 6666
666.666.6666
555 555 5555
222-222-2222
123-123-132
236-548-9888";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}