// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)CIMTS\s+[\w\s]+\s+\d{2}\/\d{2}\/\d{4}\s+(DL|DL2|D|L)").unwrap();
let string = "CIMTS Maxoel 01/01/2025 DL";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}