re = /CIMTS\s+[\w\s]+\s+\d{2}\/\d{2}\/\d{4}\s+(DL|DL2|D|L)/m
str = 'CIMTS Maxoel 01/01/2025 DL'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end