const regex = /CIMTS\s+[\w\s]+\s+\d{2}\/\d{2}\/\d{4}\s+(DL|DL2|D|L)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('CIMTS\\s+[\\w\\s]+\\s+\\d{2}\\\/\\d{2}\\\/\\d{4}\\s+(DL|DL2|D|L)', 'gm')
const str = `CIMTS Maxoel 01/01/2025 DL`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}