re = /(?i)^[a-f\d]{2}([.:-]?)([a-f\d]{2}\1){4}[a-f\d]{2}$/m
str = '01:02:03:04:ab:cd
definitely:not:a:mac
01-02-03-04-ab-cd
01.23.45.67.89.ab
0123456789ab
0000000:::::00000
0123456789abcdef:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end