$re = '/(?i)^[a-f\d]{2}([.:-]?)([a-f\d]{2}\1){4}[a-f\d]{2}$/m';
$str = '01:02:03:04:ab:cd
definitely:not:a:mac
01-02-03-04-ab-cd
01.23.45.67.89.ab
0123456789ab
0000000:::::00000
0123456789abcdef:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);