using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)^[a-f\d]{2}([.:-]?)([a-f\d]{2}\1){4}[a-f\d]{2}$";
string input = @"01:02:03:04:ab:cd
definitely:not:a:mac
01-02-03-04-ab-cd
01.23.45.67.89.ab
0123456789ab
0000000:::::00000
0123456789abcdef:";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}