#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^[a-f\d]{2}([.:-]?)([a-f\d]{2}\1){4}[a-f\d]{2}$"
Local $sString = "01:02:03:04:ab:cd" & @CRLF & _
"definitely:not:a:mac" & @CRLF & _
"01-02-03-04-ab-cd" & @CRLF & _
"01.23.45.67.89.ab" & @CRLF & _
"0123456789ab" & @CRLF & _
"0000000:::::00000" & @CRLF & _
"0123456789abcdef:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")