import Foundation
let pattern = ##"""
(?:(?:[\s\,\>]+|\b)(?:(?:(Passport|PASSI-PASS|PASSI|PASS|PASSEPORT|passaporto)\s*(?:Number|No\.*|#|ID)*))(?:[\s\,\<\.]+|\b))((?:[\s\,\>]+|\b)(?:[A-Za-z]{2}[0-9]{7})(?:[\s\,\<\.]+|\b))
|(?:[\s\,\>]+|\b)((?:[A-Za-z]{2}[0-9]{7})(?:[\s\,\<\.]+|\b))(?:(?:[\s\,\>]+|\b)(?:(?:(Passport|PASSI-PASS|PASSI|PASS|PASSEPORT|passaporto)\s*(?:Number|No\.*|#|ID)*))(?:[\s\,\<\.]+|\b))
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
er3442156 ddaf
df8998098 dfada
JH6752034 passport
passaporto YU7845329
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)