// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:(?:[\s\,\>]+|\b)(?:(?:(Passport|PASSI-PASS|PASSI|PASS|PASSEPORT|passaporto)\s*(?:Number|No\.*|#|ID)*))(?:[\s\,\<\.]+|\b))((?:[\s\,\>]+|\b)(?:[A-Za-z]{2}[0-9]{7})(?:[\s\,\<\.]+|\b))
|(?:[\s\,\>]+|\b)((?:[A-Za-z]{2}[0-9]{7})(?:[\s\,\<\.]+|\b))(?:(?:[\s\,\>]+|\b)(?:(?:(Passport|PASSI-PASS|PASSI|PASS|PASSEPORT|passaporto)\s*(?:Number|No\.*|#|ID)*))(?:[\s\,\<\.]+|\b))").unwrap();
let string = "er3442156 ddaf
df8998098 dfada
JH6752034 passport
passaporto YU7845329
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}