const regex = new RegExp('(?:(?:[\\s\\,\\>]+|\\b)(?:(?:(Passport|PASSI-PASS|PASSI|PASS|PASSEPORT|passaporto)\\s*(?:Number|No\\.*|#|ID)*))(?:[\\s\\,\\<\\.]+|\\b))((?:[\\s\\,\\>]+|\\b)(?:[A-Za-z]{2}[0-9]{7})(?:[\\s\\,\\<\\.]+|\\b))
|(?:[\\s\\,\\>]+|\\b)((?:[A-Za-z]{2}[0-9]{7})(?:[\\s\\,\\<\\.]+|\\b))(?:(?:[\\s\\,\\>]+|\\b)(?:(?:(Passport|PASSI-PASS|PASSI|PASS|PASSEPORT|passaporto)\\s*(?:Number|No\\.*|#|ID)*))(?:[\\s\\,\\<\\.]+|\\b))', 'gi')
const str = `er3442156 ddaf
df8998098 dfada
JH6752034 passport
passaporto YU7845329
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}