#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:(?:[\s\,\>]+|\b)(?:(?:(Passport|PASSI-PASS|PASSI|PASS|PASSEPORT|passaporto)\s*(?:Number|No\.*|#|ID)*))(?:[\s\,\<\.]+|\b))((?:[\s\,\>]+|\b)(?:[A-Za-z]{2}[0-9]{7})(?:[\s\,\<\.]+|\b))" & @CRLF & _
"|(?:[\s\,\>]+|\b)((?:[A-Za-z]{2}[0-9]{7})(?:[\s\,\<\.]+|\b))(?:(?:[\s\,\>]+|\b)(?:(?:(Passport|PASSI-PASS|PASSI|PASS|PASSEPORT|passaporto)\s*(?:Number|No\.*|#|ID)*))(?:[\s\,\<\.]+|\b))"
Local $sString = "er3442156 ddaf" & @CRLF & _
" df8998098 dfada" & @CRLF & _
"JH6752034 passport " & @CRLF & _
"passaporto YU7845329" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")