// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\(\-?(?:\\d(?:[\*+?]?|\{\d+(?:,\d*)?\}))*(?:\\\.(?:\\d(?:[\*+?]?|\{\d+(?:,\d*)?\}))*)?\)").unwrap();
let string = "(\\d\\d\\d\\d\\d\\d)(\\d*)(-\\.\\d{13,33}\\d?\\d\\d*) (\\w)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}