package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(\-?(?:\\d(?:[\*+?]?|\{\d+(?:,\d*)?\}))*(?:\\\.(?:\\d(?:[\*+?]?|\{\d+(?:,\d*)?\}))*)?\)`)
var str = `(\d\d\d\d\d\d)(\d*)(-\.\d{13,33}\d?\d\d*) (\w)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}