using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\-?(?:\\d(?:[\*+?]?|\{\d+(?:,\d*)?\}))*(?:\\\.(?:\\d(?:[\*+?]?|\{\d+(?:,\d*)?\}))*)?\)";
string input = @"(\d\d\d\d\d\d)(\d*)(-\.\d{13,33}\d?\d\d*) (\w)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}