$re = '/\(\-?(?:\\\\d(?:[\*+?]?|\{\d+(?:,\d*)?\}))*(?:\\\\\.(?:\\\\d(?:[\*+?]?|\{\d+(?:,\d*)?\}))*)?\)/';
$str = '(\\d\\d\\d\\d\\d\\d)(\\d*)(-\\.\\d{13,33}\\d?\\d\\d*) (\\w)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);