re = /[^<]*<div[^>]*id="number-third-digit-space"[^<]*<div[^>]*class="[^"]*(?<="|\s)contact-phone-prefix(?="|\s[^>]*)">(?<mobile>\d+).*?(\d+)/im
str = '<div class="contact-phone-icon sprite_view_icn_CnPhone"></div>
<div id="number-third-digit-space" style="display:none">
<div class="contact-phone-prefix">017</div>
<div class="contact-phone-number">3816648</div>
</div>
<div id="number-second-digit-space" style="display:none">
<div class="contact-phone-prefix">01</div>
<div class="contact-phone-number">73816648</div>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end