import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^<]*<div[^>]*id=\"number-third-digit-space\"[^<]*<div[^>]*class=\"[^\"]*(?<=\"|\\s)contact-phone-prefix(?=\"|\\s[^>]*)\">(?<mobile>\\d+).*?(\\d+)";
final String string = "<div class=\"contact-phone-icon sprite_view_icn_CnPhone\"></div>\n\n"
+ " <div id=\"number-third-digit-space\" style=\"display:none\">\n"
+ " <div class=\"contact-phone-prefix\">017</div>\n"
+ " <div class=\"contact-phone-number\">3816648</div>\n"
+ " </div>\n\n"
+ " <div id=\"number-second-digit-space\" style=\"display:none\">\n"
+ " <div class=\"contact-phone-prefix\">01</div>\n"
+ " <div class=\"contact-phone-number\">73816648</div>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}