#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ims)[^<]*<div[^>]*id="number-third-digit-space"[^<]*<div[^>]*class="[^"]*(?<="|\s)contact-phone-prefix(?="|\s[^>]*)">(?<mobile>\d+).*?(\d+)"
Local $sString = "<div class="contact-phone-icon sprite_view_icn_CnPhone"></div>" & @CRLF & _
"" & @CRLF & _
" <div id="number-third-digit-space" style="display:none">" & @CRLF & _
" <div class="contact-phone-prefix">017</div>" & @CRLF & _
" <div class="contact-phone-number">3816648</div>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div id="number-second-digit-space" style="display:none">" & @CRLF & _
" <div class="contact-phone-prefix">01</div>" & @CRLF & _
" <div class="contact-phone-number">73816648</div>" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")