using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^<]*<div[^>]*id=""number-third-digit-space""[^<]*<div[^>]*class=""[^""]*(?<=""|\s)contact-phone-prefix(?=""|\s[^>]*)"">(?<mobile>\d+).*?(\d+)";
string input = @"<div class=""contact-phone-icon sprite_view_icn_CnPhone""></div>
<div id=""number-third-digit-space"" style=""display:none"">
<div class=""contact-phone-prefix"">017</div>
<div class=""contact-phone-number"">3816648</div>
</div>
<div id=""number-second-digit-space"" style=""display:none"">
<div class=""contact-phone-prefix"">01</div>
<div class=""contact-phone-number"">73816648</div>
</div>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}