re = /^https?:\/\/ihm\.se$/m
str = 'https://ihm.se
http://ihm.se
http://qvalento.se
https://qvalento.se
matcha två översta'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end