$re = '/^https?:\/\/ihm\.se$/m';
$str = 'https://ihm.se
http://ihm.se
http://qvalento.se
https://qvalento.se
matcha två översta';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);