package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?:\/\/ihm\.se$`)
var str = `https://ihm.se
http://ihm.se
http://qvalento.se
https://qvalento.se
matcha två översta`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}