#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/ihm\.se$"
Local $sString = "https://ihm.se" & @CRLF & _
"http://ihm.se" & @CRLF & _
"http://qvalento.se" & @CRLF & _
"https://qvalento.se" & @CRLF & _
"" & @CRLF & _
"matcha två översta"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")