const regex = /[:|=|]\s*([\d|.]+)\s*-\s*([\d|.]+)\n/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[:|=|]\\s*([\\d|.]+)\\s*-\\s*([\\d|.]+)\\n', 'gmi')
const str = `#QNT
Enter range :: 0.003665-0.003819
Sell :
Target 0.003912
Target 0.004089
Target 0.004267
SL 0.003578`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}