using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[:|=|]\s*([\d|.]+)\s*-\s*([\d|.]+)\n";
string input = @"#QNT
Enter range :: 0.003665-0.003819
Sell :
Target 0.003912
Target 0.004089
Target 0.004267
SL 0.003578";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}