package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[:|=|]\s*([\d|.]+)\s*-\s*([\d|.]+)\n`)
var str = `#QNT
Enter range :: 0.003665-0.003819
Sell :
Target 0.003912
Target 0.004089
Target 0.004267
SL 0.003578`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}