#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)[:|=|]\s*([\d|.]+)\s*-\s*([\d|.]+)\n"
Local $sString = "#QNT " & @CRLF & _
"Enter range :: 0.003665-0.003819" & @CRLF & _
"Sell :" & @CRLF & _
"Target 0.003912" & @CRLF & _
"Target 0.004089" & @CRLF & _
"Target 0.004267" & @CRLF & _
"SL 0.003578"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")