// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Z]{3}-\d{4}|[A-Z]{3}\d[A-Z]\d{2}").unwrap();
let string = "ABC-1234, RTE5J78, XYZ-9876, WSD4K22";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}