$re = '/[A-Z]{3}-\d{4}|[A-Z]{3}\d[A-Z]\d{2}/m';
$str = 'ABC-1234, RTE5J78, XYZ-9876, WSD4K22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);