re = /[A-Z]{3}-\d{4}|[A-Z]{3}\d[A-Z]\d{2}/m
str = 'ABC-1234, RTE5J78, XYZ-9876, WSD4K22'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end