const regex = /[A-Z]{3}-\d{4}|[A-Z]{3}\d[A-Z]\d{2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z]{3}-\\d{4}|[A-Z]{3}\\d[A-Z]\\d{2}', 'gm')
const str = `ABC-1234, RTE5J78, XYZ-9876, WSD4K22`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}