import Foundation
let pattern = #"("|')((?!(?!\\)(\1|\n))|(\\(.|\n))|((?!\\).))*?(\1)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"valid line"
'valid line 2'
''
""
"'''"
"''''"
'"""'
'""""'
"hello new line\
hello another line\
end blank line"
'hello blank line\
\ \\g\
end blank line'
"\'"
"\""
"errors"
"broken line
"
'broken line
'
"broken line 2 \ffd
\hellod
"
'\'
"\"
"""
'''
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"newstr"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)