re = /("|')((?!(?!\\)(\1|\n))|(\\(.|\n))|((?!\\).))*?(\1)/
str = '"valid line"
\'valid line 2\'
\'\'
""
"\'\'\'"
"\'\'\'\'"
\'"""\'
\'""""\'
"hello new line\\
hello another line\\
end blank line"
\'hello blank line\\
\\ \\\\g\\
end blank line\'
"\\\'"
"\\""
"errors"
"broken line
"
\'broken line
\'
"broken line 2 \\ffd
\\hellod
"
\'\\\'
"\\"
"""
\'\'\'
'
subst = 'newstr'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result