import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"|')((?!(?!\\\\)(\\1|\\n))|(\\\\(.|\\n))|((?!\\\\).))*?(\\1)";
final String string = "\"valid line\"\n\n"
+ "'valid line 2'\n\n"
+ "''\n\n"
+ "\"\"\n\n"
+ "\"'''\"\n"
+ "\"''''\"\n"
+ "'\"\"\"'\n"
+ "'\"\"\"\"'\n\n"
+ "\"hello new line\\\n"
+ "hello another line\\\n"
+ "end blank line\"\n\n"
+ "'hello blank line\\\n"
+ "\\ \\\\g\\\n"
+ "end blank line'\n\n"
+ "\"\\'\"\n\n"
+ "\"\\\"\"\n\n"
+ "\"errors\"\n\n"
+ "\"broken line\n"
+ "\"\n\n"
+ "'broken line \n"
+ "'\n\n"
+ "\"broken line 2 \\ffd\n"
+ "\\hellod\n"
+ "\"\n"
+ "'\\'\n"
+ "\"\\\"\n"
+ "\"\"\"\n\n"
+ "'''\n";
final String subst = "newstr";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}