const regex = new RegExp('("|\\')((?!(?!\\\\)(\\1|\\n))|(\\\\(.|\\n))|((?!\\\\).))*?(\\1)', 'g')
const str = `"valid line"
'valid line 2'
''
""
"'''"
"''''"
'"""'
'""""'
"hello new line\\
hello another line\\
end blank line"
'hello blank line\\
\\ \\\\g\\
end blank line'
"\\'"
"\\""
"errors"
"broken line
"
'broken line
'
"broken line 2 \\ffd
\\hellod
"
'\\'
"\\"
"""
'''
`;
const subst = `newstr`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);