import Foundation
let pattern = #"[^a-zA-Z,]\d+((\,\d+(\+|\-|\*|\/)\d+(\,\d+|))|((\+|\-|\*|\/)(\d+(\,\d+|))))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
10,10 + 9, 9
10,1,0+9,9
10,10,+,9,9
10,10+9,9
10+9,0
10,0+9
10+9
10,0+9,4
10,2+3
,?(\d+)?|(\+|-|\*|\/|\,|)
(\+|\-|\*|\/)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)