const regex = /[^a-zA-Z,]\d+((\,\d+(\+|\-|\*|\/)\d+(\,\d+|))|((\+|\-|\*|\/)(\d+(\,\d+|))))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Z,]\\d+((\\,\\d+(\\+|\\-|\\*|\\\/)\\d+(\\,\\d+|))|((\\+|\\-|\\*|\\\/)(\\d+(\\,\\d+|))))', 'g')
const str = `10,10 + 9, 9
10,1,0+9,9
10,10,+,9,9
10,10+9,9
10+9,0
10,0+9
10+9
10,0+9,4
10,2+3
,?(\\d+)?|(\\+|-|\\*|\\/|\\,|)
(\\+|\\-|\\*|\\/)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}