// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^a-zA-Z,]\d+((\,\d+(\+|\-|\*|\/)\d+(\,\d+|))|((\+|\-|\*|\/)(\d+(\,\d+|))))").unwrap();
let string = "10,10 + 9, 9
10,1,0+9,9
10,10,+,9,9
10,10+9,9
10+9,0
10,0+9
10+9
10,0+9,4
10,2+3
,?(\\d+)?|(\\+|-|\\*|\\/|\\,|)
(\\+|\\-|\\*|\\/)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}