// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(thanks).*(lyrics)").unwrap();
let string = "Thanks to yo momma for sending these lyrics
Thanks bruh
yo boi gimme dem lyrics
how about no thanks for the lyrics tho";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}