import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(thanks).*(lyrics)";
final String string = "Thanks to yo momma for sending these lyrics\n\n"
+ "Thanks bruh\n\n"
+ "yo boi gimme dem lyrics\n\n"
+ "how about no thanks for the lyrics tho";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}