package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(thanks).*(lyrics)`)
var str = `Thanks to yo momma for sending these lyrics
Thanks bruh
yo boi gimme dem lyrics
how about no thanks for the lyrics tho`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}