#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(thanks).*(lyrics)"
Local $sString = "Thanks to yo momma for sending these lyrics" & @CRLF & _
"" & @CRLF & _
"Thanks bruh" & @CRLF & _
"" & @CRLF & _
"yo boi gimme dem lyrics" & @CRLF & _
"" & @CRLF & _
"how about no thanks for the lyrics tho"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")